THMPR Demo Support thread!

Damiv

Commander
Jan 26, 2017
7
17
3
#2
Hello,

When I try to log into the demo, I get "User Not Found". I tried my email and my user name to no avail. Tripple checked my password. Am I missing something?
 

Maven

Kaiju Slayer
Max Kahuna
Jul 26, 2016
247
1,122
93
#3
Hello,

When I try to log into the demo, I get "User Not Found". I tried my email and my user name to no avail. Tripple checked my password. Am I missing something?
Couple of things you could check:

The info you enter is case sensitive.
The User ID from the backer page needs to have the number tag at the end.
Try copy-pasting the user ID instead of manually entering the data
 

Maven

Kaiju Slayer
Max Kahuna
Jul 26, 2016
247
1,122
93
#6
@ion_vash#1256

Provided you are a backer at the $35 tier, you will find the download here:

https://my.em8er.com/downloads

The latest build is: LATEST - THMPR Multiplayer Demo - Call down the THMPR and harvest minerals for the first time!

If you are only a subscriber however, you will have access only to the build before this one: Assault Rifle December Test - Our first real assault rifle demo with PvP and PvE servers, up to 100 players each!
 

Maven

Kaiju Slayer
Max Kahuna
Jul 26, 2016
247
1,122
93
#8
Oh that's not really clear why would someone pay $7 a month to have access to basically nothing
While this isn't really the place to discuss this:

The description of the subscriber program quite explicitly states that you get access to a build one behind the ones currently available to backers. See below:

dev build.JPG

From: https://my.em8er.com/perks

However, subscribers also get access to unique skins, Vision Book updates, the Ruleset for the TableTop RPG Gatestriders, and a novel being written, set in the Em-8ER universe. These are unique rewards exclusive to subscribers and not available to regular backers.
 

DoktOrk

Deepstriker
Omega Founder
Jan 7, 2018
48
114
33
#9
Hi All!

Is it possible that in my options there is no mouse sensitivity?
(I know I mentioned this before, since I thaught it is a feature for later on but other players told me they could modify it, so I checked it again and again but it does not appear on the screen in the options menu [Esc].)
Edit: Maven answered the question. I was simply blind... :-D

An other strange thing is:
I downloaded the latest THMPR build.
I extracted.
I ran the exe.
In the game - after 3 minutes or so - I changed from
Fullscreen mode: Maximized window
to
Fullscreen mode: Fullscreen.
Since then I can not launch the game, not even the login screen.
I deleted the other builds.
Still could not launch.
I deleted everything and downloaded and extracted the same build once more.
Still nothing.
I could get the following error message as I hit ctrl-alt-del with the title: "The UE4-Em8erMovement Game has been crashed and will close":
"Fatal error: [File: Unknown] [Line: 249]
Result failed
at
C:/work/uesource/4-23-1/Engine/Source/Runtime/Windows/D3D11RHI/Private/D3D11Viewport.cpp:368
with error DXGI_ERROR_INVALID_CALL"

I restarted my computer and tried to launch the game again.
Still the same.
I could not figure it out what was changed (system or DirectX or something else...) in the background, so I could not revert the changes.

Edit:
I changed FullscreenMode to 2 in the file
C:\Users\username\AppData\Local\Em8erMovement\Saved\Config\WindowsClient\GameUserSettings.ini
but I run into the same problem.

Edit2:
My video card: NVIDIA GeForce GTX 1050, so I hope it is not a D3D feature too high for this...
I have found something similar, an issue with the UE: https://issues.unrealengine.com/issue/UE-81742, but if this is the cause, I can not resolve it.


Any help is appreciated.

Cheers: DoktOrk :-D

(Sorry if this question was answered before and I did not find it.)
 
Last edited:

HarryPearce

New Member
Staff member
Ember Dev
Apr 25, 2018
3
12
3
#10
An other strange thing is:
I downloaded the latest THMPR build.
I extracted.
I ran the exe.
In the game - after 3 minutes or so - I changed from
Fullscreen mode: Maximized window
to
Fullscreen mode: Fullscreen.
Since then I can not launch the game, not even the login screen.
I deleted the other builds.
Still could not launch.
I deleted everything and downloaded and extracted the same build once more.
Still nothing.
I could get the following error message as I hit ctrl-alt-del with the title: "The UE4-Em8erMovement Game has been crashed and will close":
"Fatal error: [File: Unknown] [Line: 249]
Result failed
at
C:/work/uesource/4-23-1/Engine/Source/Runtime/Windows/D3D11RHI/Private/D3D11Viewport.cpp:368
with error DXGI_ERROR_INVALID_CALL"

I restarted my computer and tried to launch the game again.
Still the same.
I could not figure it out what was changed (system or DirectX or something else...) in the background, so I could not revert the changes.

Edit:
I changed FullscreenMode to 2 in the file
C:\Users\username\AppData\Local\Em8erMovement\Saved\Config\WindowsClient\GameUserSettings.ini
but I run into the same problem.

Edit2:
My video card: NVIDIA GeForce GTX 1050, so I hope it is not a D3D feature too high for this...
I have found something similar, an issue with the UE: https://issues.unrealengine.com/issue/UE-81742, but if this is the cause, I can not resolve it.


Any help is appreciated.

Cheers: DoktOrk :-D

(Sorry if this question was answered before and I did not find it.)
Two things you can try, first go into that file

C:\Users\username\AppData\Local\Em8erMovement\Saved\Config\WindowsClient\GameUserSettings.ini

and find all occurrences of FullscreenMode, it is likely, that if you played previous builds there is more than one, due to changes in the code. Look for headings [/Script/Engine.GameUserSettings] and [/Script/Em8erMovement.Em8erUserSettings]. The latter is the one in use presently.

If that doesn't work, try deleting the file entirely, starting the game, and if it still crashes the same way, check back into the file and change it again.
 

JakeDaltara

Tsi-Hu Hunter
May 6, 2017
4
7
3
Canada
#11
I'm a little late to the party, but I'm having trouble getting the demo to play.
I'm able to log in, but then I'm greeted with a sub-surface view, and controls / Esc. are not responsive. (I had to Alt+F4 to quit).
Just in case, I tried re-downloading the demo, same results. THMPRDemo.jpg
Any suggestions?
Edit: The trees / water are moving slightly, it's not frozen completely.
 

Pandagnome

Kaiju Slayer
Happy Kaiju
Jul 27, 2016
4,965
6,408
113
Island of Tofu
#12
I'm a little late to the party, but I'm having trouble getting the demo to play.
I'm able to log in, but then I'm greeted with a sub-surface view, and controls / Esc. are not responsive. (I had to Alt+F4 to quit).
Just in case, I tried re-downloading the demo, same results. View attachment 3506
Any suggestions?
Edit: The trees / water are moving slightly, it's not frozen completely.

You could try these steps ignore installing the driver tool

https://www.drivereasy.com/knowledge/fix-computer-freezes-when-playing-games-easily/

perhaps computer is overheating is cooling good?
Perhaps computer needs a little clean from dust?
Perhaps some unwanted software or files taking space in hard drive could be removed?

That's what i would do but perhaps someone might have a better idea & also wonder what your computer specs are hmm


Hope you get the demo to work soon!
 

HarryPearce

New Member
Staff member
Ember Dev
Apr 25, 2018
3
12
3
#13
I'm a little late to the party, but I'm having trouble getting the demo to play.
I'm able to log in, but then I'm greeted with a sub-surface view, and controls / Esc. are not responsive. (I had to Alt+F4 to quit).
Just in case, I tried re-downloading the demo, same results. View attachment 3506
Any suggestions?
Edit: The trees / water are moving slightly, it's not frozen completely.
Whenever you are stuck under the map but the game seems to still work, that is an known issue we are trying to fix for a long time. We fix it for now by restarting servers, so whenever that happens just notify me or grummz and we restart it. The game should work now.
 

DoktOrk

Deepstriker
Omega Founder
Jan 7, 2018
48
114
33
#14
find all occurrences of FullscreenMode, it is likely, that if you played previous builds there is more than one, due to changes in the code. Look for headings [/Script/Engine.GameUserSettings] and [/Script/Em8erMovement.Em8erUserSettings]. The latter is the one in use presently.

If that doesn't work, try deleting the file entirely, starting the game, and if it still crashes the same way, check back into the file and change it again
Harry for President! :-D

I changed all fullscreen occurences to 2 in the file
GameUserSettings.ini.
The game could not run after that so I deleted and reinstalled the build, and that did the job.

Thank you for the help!

Cheers: DoktOrk :-D
 

Pandagnome

Kaiju Slayer
Happy Kaiju
Jul 27, 2016
4,965
6,408
113
Island of Tofu
#15
I'm a little late to the party, but I'm having trouble getting the demo to play.
I'm able to log in, but then I'm greeted with a sub-surface view, and controls / Esc. are not responsive. (I had to Alt+F4 to quit).
Just in case, I tried re-downloading the demo, same results. View attachment 3506
Any suggestions?
Edit: The trees / water are moving slightly, it's not frozen completely.
Just tried and seems mine is doing this too i am considering this as my new wall paper.